Back to overview
Downtime

Frankfurt Server Down

May 02 at 01:37pm CEST
Affected services
fuxam.app

Resolved
May 02 at 01:52pm CEST

We are back on track. Sorry for the inconvenience.

Created
May 02 at 01:37pm CEST

The servers in Frankfurt are currently offline, and we are investigating the issue.